Warning: Function get_magic_quotes_gpc() is deprecated in /home/eventpho/public_html/forum/includes/class_core.php on line 1960
Install issue with DNP firmware installation FIX ! [Archive] - Event Photographer Society Forum


View Full Version : Install issue with DNP firmware installation FIX !

Alan Warner
14-07-2010, 07:33 PM
The clever people at DNP have screwed the installation routine,

One very common problem is the MSCOMCTL.OCX.

To correct the error, first search your drive for MSCOMCTL.OCX to see if you have it already (should be in the downloaded update file)

The file should be placed in your C:\WINDOWS\SYSTEM directory. Or, if you are C:\WINDOWS\SYSTEM32 if you are using WinXP.

Once it is there click START--> RUN and type "REGSVR32 MSCOMCTL.OCX" (No quotes) in the box.

That should fix the problem, you may also need to update you .NET framework to v2.*+


It works 100% !


Ed Brown
14-07-2010, 07:34 PM
Decent content, just what this place needs, nice one Al

Alan Warner
14-07-2010, 07:35 PM
Makes a change to have decent content from me eh ?


14-07-2010, 08:06 PM
Thanks Alan. I'll try that tomorrow.


Mark Amies
15-07-2010, 08:04 AM
Thank you for the feedbak Mr Warner , I will make sure it is noted. :diff:

Alan Warner
19-07-2010, 04:05 PM

Did you succeed ?


19-07-2010, 04:55 PM
Hi Al
Sorry I should have posted earlier!! Yes I have succeeded, but not without trial and tribulation. Windows 7! There! Now I've said it! It wouldn't let me install mscomctl.ocx without a lot of hassle. Seems regsvr32 doesn't like running in 64bit enviroment. Long story short..... installed firmware update on an xp machine. Thanks

Kev :puter:

Alan Warner
19-07-2010, 05:26 PM
Glad to hear Have

Did you also load the DNP utility to read remaining prints ect ?


19-07-2010, 05:29 PM
Yes I did thanks Al. I'm all setup with it now. Just need a bit more work so's I can use it!!

30-07-2010, 07:10 PM
I am stuck ! Can anyone help please
Downloaded the new firmware and then tried to install DS40_0104 and it flashes up

Run Time Error 48
File not found cxstat.dll

Any ideas ?

30-07-2010, 07:17 PM
by the way, i am running Windows 7 and the old firmware worked fine :cry:

Alan Warner
31-07-2010, 07:45 AM
Hi Natalie,

The Fix is for The Same issue !

The file cxstat.dll need to be located in the relevant windows systems folder (its missing or rather not installed as DNP expected)

I don't use Win 7 so have no idea i'm afraid

This appears to be a file that has been missed by DNP, as its growing unlikely that those upgrading have all removed the same file (mine from a clean install)


01-08-2010, 09:05 PM
thanks Alan - have re-installed the old ones for the time being and will have a play