Warning: Function get_magic_quotes_gpc() is deprecated in /home/eventpho/public_html/forum/includes/class_core.php on line 1960
Event View Mac setup [Archive] - Event Photographer Society Forum

PDA

View Full Version : Event View Mac setup



Russ Hill
22-07-2010, 11:48 PM
Hello

I am trying to get Mikes Viewer software working on my Macbook Pro and having limited success. The installation instructions do lean toward Windows so I am asking if there is documentation for us Mac users available.

I have Mac with OSX 10.6.4 operating system.


The following software has been downloaded and installed.
Jalbum 8.9.2
Xampp 1.7.3
Firefox 3.6.7

Computer Status:
Apache running
MySQL running.
Firefox on-line
Event View has been added to the Jalbum skins directory and settings selected as instructed.
Internet turned off
MySQL database created named "Sudbury" (no tables)
Database username = root password = root
Output Directory = /Users/russhill/Sites/sudbury

I have not been able to point my internet browser to "http://localhost/ControlPanel.php" because I can not find or do not have this Control Panel. I did find a ControlPanel.htt in the Event Viewer skin but it did not work.

I have created an album with Jalbum and am able to view the images at "http://localhost/sudbury/" in Firefox. I can see where the buttons are intended to be but they do not function. I get results like: Object not found! The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated.

Event Viewer functions such as Order handling, Sales etc are nowhere to be found.

Looking at the MySQL Sudbury data base nothing has changed. No table created etc. so I assume this is a big part of my problem.

Any help would be appreciated

Thanks a bunch

Russ

simon coates
23-07-2010, 07:08 AM
Hi

I ran it successfully on a Mac using MAMP rather than XAMPP. The key thing is to publish it to the correct folder in the MAMP directory, not the Users/sites folder.

Simon

Russ Hill
24-07-2010, 12:32 PM
Thanks Simon

I loaded MAMP which worked well. With a little more fiddling I found an invalid path Jalbum output. I had typed in the path originally which did not work. When I used the drag and drop function offered in the Jalbums output things started working. The path looks exactly the same but must have had some hidden bits mucking things up. I will now play with it and try to setup the remote viewing station.

Many thanks go out to Mike for this handy little tool.

Thanks very much for the feedback.

Russ

Proinsias Tully
05-07-2011, 03:13 PM
Hi, I am looking for a word version of the instructions so I can edit them to document my process. I am using an Imac and have it working and I just want to tidy up a guidance document,

Thanks, Bob